Spherical Easel

A spherical drawing program


Spherical Easel is a program for creating diagrams in spherical geometry that may be easily reconfigured. In this sense, it is similar to The Geometer's Sketchpad and Non-Euclid. Spherical Easel is designed to be easy to use and will often lead you through the construction of a diagram. These notes aim to give a complete description of the program and its features.

Spherical Easel's Interface

When Spherical Easel is open, you will see an interface like this:

This consists of several parts:

  1. a figure on which to draw.

    Notice that there is a message displayed in the bottom of the figure:

    Generally speaking, Spherical Easel is at all times ready to perform some action. The message at the bottom of the figure usually gives information about what action is ready to be taken and instructions as to how to perform the action.

  2. controls for selecting the current action.

  3. a taskbar for managing several different figures.

    A new figure may be created using the New option under the File menu item. Notice that each figure has a corresponding button in the taskbar. These buttons may be used to control the state of a figure.

    While several independent figures may be displayed at once, only one figure is the current figure to which changes may be made. A figure may become the current figure by either clicking on it or clicking its corresponding button in the taskbar. Figures may be resized, closed or iconified using the buttons in the upper right hand corner of the window holding the figure.

Back to top

Adding and Moving Elements in a Figure

There are four basic types of elements that can be added directly to a figure: points, lines, line segments and circles. To add one of these elements, select the appropriate button on the controls shown to the right and follow the instructions given.

Notice that points may be a part of several elements in a figure. For instance, in the figure to the left, the point B is an endpoint of two different line segments. This is achieved by first defining the segment AB and beginning the definition of BC by clicking in the point B.

Individual elements in a figure may be moved by selecting the Move button. This is perhaps the most important, and useful, feature of Spherical Easel:

When an element is moved, any other elements that depend on it are moved as well.
For instance, if we move the point B in the diagram, both line segments AB and BC will move as well.

Generally speaking, points are the only elements that can be moved. This makes a certain amount of sense: since lines are defined in terms of two points, we should move the points to move the line. However, there is one exception to this rule: when the two points are antipodal, the line or line segment they define is not unique and it may therefore be moved.

Once some elements have been added to the figure, the sphere may be rotated using the Rotate button. Once this is selected, the sphere may be rotated by clicking and dragging in the direction of the desired rotation.

There are two features that make geometry on the sphere rather unique.

  1. You will quickly notice that the sphere has a front and a back. Points may be defined or moved on the back of the sphere by pressing the Ctrl key while performing the necessary mouse operations.

  2. It can be difficult to draw a line segment between two points which are nearly antipodal since the line segment is very sensitive to small differences in the endpoints. To help with this, it is possible to constrain a line segment, while being defined or moved, to lie on a given line by pressing the Shift key while moving one of its endpoints.

Back to top

File Operations

Shown below are the File menus from the applet and application version of Spherical Easel.

Applet version Application version

As you can see, the file operations avaiable when running Spherical Easel as an applet are somewhat restricted. In particular, files cannot be saved, reloaded or printed. This is due to security restrictions placed on applets running inside web browsers.

The only menu item that may need explaining is Print to PS. This will produce a version of the current figure in PostScript and either save it to a file, in the application version, or display it in a text window, in the applet version, from which it may be cut and pasted into a file. From here, the figure may easily be included in text documents.

The Close menu item will close the current figure.

Back to top

The Edit Menu

The Edit menu allows the appearance of a figure to be customized.

The last change made may be set aside using the Undo menu item.

The Delete menu item will delete any elements from a figure that are subsequently selected. When an element is deleted, any element that depends on that element is necessarily deleted as well.

When figures get rather complicated, it is often convenient to Hide some of the earlier elements. This is not the same as Delete: when an element is hidden, it still exists but is just not displayed. Hidden elements may be redisplayed using the Show Hidden menu item.

Every element added to a figure is labelled. However, these labels are not shown by default. To see the label of a particular element, choose the Show Label menu item and select the element. All labels may be shown using Show All Labels.

Elements in a figure usually have some properties, such as the color and label, that may be edited using the Properties menu item. When an element is selected, a dialog like that on the left is initiated. The dialog shown results from editing a line's properties. The label, whether the label is hidden, the color of the line, its thickness and whether it is dashed may all be modified.

Finally, you will notice that elements on the back of the sphere are drawn in a slightly lighter color to indicate that they are on the back. Depending on your monitor and the conditions under which you are viewing Spherical Easel, you may wish to increase this contrast between the front and the back using the Front/Back Contrast menu item.

Back to top


Once some elements have been defined in a figure, it is often desirable to construct some other elements based on those. The Construction Menu, shown on the right, allows for some common constructions. As usual, the desired construction should first be selected. Instructions will appear that lead you through the particular construction.

Most of the constructions are straightforward. Please note, however, that when Parallel transport is selected followed by a closed path of line segments, you will see a vector that may be dragged along the path thus demonstrating the notion of parallel transport.

Back to top


Various measurements may be made as indicated by the Measurement menu shown on the left. Again, most of these are fairly straightforward. Please note that the order in which line segments are selected determines which of the two possible oriented angles is chosen. Also note that distances and angle measures are usually displayed as multiples of .

When a measurement is made, a separate window containing the measurements will appear. This window may be hidden if desired. Most windowing systems allow windows like this to be set so that they will always stay on top of other windows. Notice that, in keeping with the spirit of Spherical Easel, the measurements will be updated as elements in the figured are moved.

The Calculator menu item allows you to study quantities that depend on other measurements made. This calculator, whose syntax is modelled on Maple's, supports a wide range of mathematical functions including the trigonometric, logarithm and exponential functions (inverse trigonometric functions are denoted by atan, asin, and acos). Notice that each measurement is given a label by which it may be referenced in an expression. For example, entering sin(M0 + M1) would display the sine of the sum of the measurements labeled M0 and M1.

Finally, measurements may be deleted by first selecting the Delete Measurement menu item and then clicking on the desired measurement.

Back to top


Spherical Easel allows you to work with the standard isometries--reflections, translations and rotations--using the Isometry Menu. Generally speaking, you will be asked to select an element, either a line or line segment or point, to define the isometry. Then you may select elements on which you want the isometry to act.

Please notice that the angle of rotation may be controlled by moving the point on the rotation tool displayed.

Back to top

Contact Information

Spherical Easel was created by David Austin and William Dickinson for educational purposes. We would like to hear how you are using Spherical Easel, any improvements you feel could be made and, especially, any bugs or other quirky behavior you find.

Thank you for using Spherical Easel.

© 2002-2008 David Austin and William Dickinson

Spherical Easel Home Page